summaryrefslogtreecommitdiffstats
path: root/data/themes/ulticontroller_2.0/Makefile.am
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2015-01-28 21:16:19 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2015-01-28 21:16:19 (GMT)
commit875a697287f7f01cf181a3b47974c9f730fd86e1 (patch)
tree4902efb052a97ff8e5db2058dd93d68fb3bc8234 /data/themes/ulticontroller_2.0/Makefile.am
parent252a3bbc3f60ff8d7d8bceefc85286b7fcf97842 (diff)
downloadeulogium-875a697287f7f01cf181a3b47974c9f730fd86e1.zip
eulogium-875a697287f7f01cf181a3b47974c9f730fd86e1.tar.gz
eulogium-875a697287f7f01cf181a3b47974c9f730fd86e1.tar.bz2
temp
Diffstat (limited to 'data/themes/ulticontroller_2.0/Makefile.am')
-rw-r--r--data/themes/ulticontroller_2.0/Makefile.am40
1 files changed, 29 insertions, 11 deletions
diff --git a/data/themes/ulticontroller_2.0/Makefile.am b/data/themes/ulticontroller_2.0/Makefile.am
index 4629bc3..6746843 100644
--- a/data/themes/ulticontroller_2.0/Makefile.am
+++ b/data/themes/ulticontroller_2.0/Makefile.am
@@ -1,21 +1,39 @@
AUTOMAKE_OPTIONS = subdir-objects
MAINTAINERCLEANFILES = Makefile.in
-EXTRA_DIST = \
-splashscreen.edc \
+include ../../../Makefile_Edje_Helper.am
+
+images = \
images/ultimaker_logo.png
-include ../../../Makefile_Edje_Helper.am
+fonts =
+
+sounds =
+
+vibrations =
+
+data =
+
+edjes = \
+splashscreen.edc \
+mainscreen.edc
+
+ULTICONTROLLER_CC_FLAGS = \
+-id ${top_srcdir}/data/themes/ulticontroller_2.0/images \
+-fd ${top_srcdir}/data/themes/ulticontroller_2.0/fonts \
+-sd ${top_srcdir}/data/themes/ulticontroller_2.0/sounds \
+-vd ${top_srcdir}/data/themes/ulticontroller_2.0/vibrations \
+-dd ${top_srcdir}/data/themes/ulticontroller_2.0/data
+
+EXTRA_DIST = $(images) $(sounds) $(iamges) $(edjes)
filesdir = $(datadir)/$(PACKAGE)/themes
-files_DATA = splashscreen.edj
-
-splashscreen.edj: Makefile $(EXTRA_DIST)
- $(AM_V_EDJ)$(EDJE_CC) $(EDJE_CC_FLAGS) \
- -id ${top_srcdir}/data/themes/ulticontroller_2.0/images \
- -sd ${top_srcdir}/data/themes/ulticontroller_2.0/sounds \
- $(top_srcdir)/data/themes/ulticontroller_2.0/splashscreen.edc \
- $(top_builddir)/data/themes/ulticontroller_2.0/splashscreen.edj
+files_DATA = ulticontroller_2.0.edj
+
+ulticontroller_2.0.edj: Makefile $(EXTRA_DIST)
+ $(AM_V_EDJ)$(EDJE_CC) $(EDJE_CC_FLAGS) $(ULTICONTROLLER_CC_FLAGS) \
+ $(top_srcdir)/data/themes/ulticontroller_2.0/ulticontroller_2.0.edc \
+ $(top_builddir)/data/themes/ulticontroller_2.0/ulticontroller_2.0.edj
clean-local:
rm -f *.edj