summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2015-01-24 16:33:38 (GMT)
committerOlliver Schinagl <o.schinagl@ultimaker.com>2015-04-28 05:07:12 (GMT)
commitfcc9a7cc3f0ca7e95085bfdc278e3736692730a4 (patch)
tree1f9c4cf34cd600176b100e1afbbc59a2e6dca550 /src/Makefile.am
parent08cfb908c22c0c7b5aeb788569950718939b7465 (diff)
downloadeulogium-fcc9a7cc3f0ca7e95085bfdc278e3736692730a4.zip
eulogium-fcc9a7cc3f0ca7e95085bfdc278e3736692730a4.tar.gz
eulogium-fcc9a7cc3f0ca7e95085bfdc278e3736692730a4.tar.bz2
wip commit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 15871c9..a0417e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,18 @@
MAINTAINERCLEANFILES = Makefile.in
-SUBDIRS = lib bin tests
+SUBDIRS = tests
+bin_PROGRAMS = eulogium
+
+AM_CPPFLAGS = -DPACKAGE_BIN_DIR=\"$(bindir)/\" \
+ -DPACKAGE_LIB_DIR=\"$(bindir)/\" \
+ -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \
+-I$(top_builddir)/src/ \
+-I$(top_srcdir)/src/ \
+@EFL_CFLAGS@
+
+eulogium_SOURCES = eulogium.c
+eulogium_LDADD = @EFL_LIBS@
+
+localedir = $(datadir)/locale
+DEFS = -DLOCALE_DIR=\"$(localedir)\" @DEFS@