summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 8 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index da5e488..05144d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-EFL_VERSION([1], [8], [5])
-AC_INIT([eulogium], [m4_esyscmd_s([git describe --always --tags --abbrev=1 --dirty])], [support@ultimaker.com], [], [http://www.ultimaker.com])
+EFL_VERSION([1], [8], [5], [0])
+AC_INIT([eulogium], [m4_esyscmd_s([git describe --always --tags --dirty --abbrev=1])], [support@ultimaker.com], [], [http://www.ultimaker.com])
AC_PREREQ([2.65])
AC_CONFIG_SRCDIR([configure.ac])
@@ -30,25 +30,14 @@ EFL_CHECK_PATH_MAX
# Check for EFL
PKG_CHECK_MODULES([EFL],
[
- ecore >= 1.8.0
- ecore-evas >= 1.8.0
- eina >= 1.8.0
- elementary >= 1.8.0
- evas >= 1.8.0
- eeze >= 1.8.0
+ ecore >= 1.8.5
+ ecore-evas >= 1.8.5
+ eina >= 1.8.5
+ elementary >= 1.8.5
+ evas >= 1.8.5
+ eeze >= 1.8.5
])
-# Check for tests and coverage
-AC_ARG_WITH([tests],
- [AC_HELP_STRING(
- [--with-tests=none|regular|coverage],
- [choose testing method: regular, coverage or none. @<:@default=none@:>@])],
- [build_tests=${withval}],
- [build_tests=auto]
-)
-
-EFL_TESTS([${build_tests}])
-
# doxygen program for documentation building
EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"])
@@ -68,7 +57,6 @@ data/desktop/Makefile
data/desktop/eulogium.desktop
data/themes/Makefile
data/themes/default/Makefile
-data/themes/ulticontroller_2.0/Makefile
doc/Makefile
packaging/Makefile
packaging/slackware/Makefile
@@ -76,7 +64,6 @@ packaging/debian/Makefile
packaging/pkgbuild/Makefile
po/Makefile.in
src/Makefile
-src/tests/Makefile
doc/eulogium.1
])
AC_OUTPUT