summaryrefslogtreecommitdiffstats
path: root/data/themes/default/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/themes/default/Makefile.am')
-rw-r--r--data/themes/default/Makefile.am76
1 files changed, 66 insertions, 10 deletions
diff --git a/data/themes/default/Makefile.am b/data/themes/default/Makefile.am
index 8c9ea90..c67f0a1 100644
--- a/data/themes/default/Makefile.am
+++ b/data/themes/default/Makefile.am
@@ -5,30 +5,38 @@ include ../../../Makefile_Edje_Helper.am
EDJE_CC_FLAGS += #-l $(top_srcdir)/COPYING -a $(top_srcdir)/AUTHORS
-filesdir = $(datadir)/elementary/themes
+filesdir = $(datadir)/$(PACKAGE)/themes
files_DATA = default.edj
+EDJE_CC_FLAGS += \
+-id ${top_srcdir}/data/themes/default/img \
+-fd ${top_srcdir}/data/themes/default/fnt \
+-sd ${top_srcdir}/data/themes/default/snd \
+-dd ${top_srcdir}/data/themes/default/data
+
default.edj: Makefile $(EXTRA_DIST)
$(AM_V_EDJ)$(EDJE_CC) \
- $(EDJE_CC_FLAGS) -fastdecomp \
+ $(EDJE_CC_FLAGS) -fastdecomp -w files.txt -deps deps.txt -v \
$(top_srcdir)/data/themes/default/default.edc \
$(top_builddir)/data/themes/default/default.edj
clean-local:
rm -f *.edj
-EDJE_CC_FLAGS += \
--id ${top_srcdir}/data/themes/default/img \
--fd ${top_srcdir}/data/themes/default/fnt \
--sd ${top_srcdir}/data/themes/default/snd \
--dd ${top_srcdir}/data/themes/default/data
-
EXTRA_DIST = ${images} ${fonts} ${sounds} ${data} ${edjes}
data =
fonts = \
-fnt/5x7.pcf.gz
+fnt/4x6.pcf \
+fnt/5x7.pcf \
+fnt/5x8.pcf \
+fnt/6x9.pcf \
+fnt/6x12.pcf \
+fnt/7x13.pcf \
+fnt/8x13.pcf \
+fnt/9x15.pcf \
+fnt/10x20.pcf
sounds = \
snd/kbd-tap.wav \
@@ -38,6 +46,7 @@ snd/kbd-tap4.wav \
snd/kbd-tap5.wav
edjes = \
+default.edc \
colorclasses.edc \
fonts.edc \
macros.edc \
@@ -98,4 +107,51 @@ edc/elm/tooltip.edc \
edc/elm/video.edc \
edc/elm/win.edc
-images =
+images = \
+img/slider_run_base_horiz.png \
+img/slider_run_bevel_horiz.png \
+img/slider_run_base_light_horiz.png \
+img/slider_indicator_knob_horiz.png \
+img/button_normal.png \
+img/button_outline.png \
+img/bevel_in.png \
+img/sym_check_alum.png \
+img/inset_bar_horiz_base.png \
+img/inset_bar_horiz_glow_base.png \
+img/inset_bar_horiz_glow_inv_base.png \
+img/inset_bar_horiz_glow_mid_base.png \
+img/inset_bar_vert_base.png \
+img/inset_bar_vert_glow_base.png \
+img/inset_bar_vert_glow_inv_base.png \
+img/inset_bar_vert_glow_mid_base.png \
+img/knob_round_busy.png \
+img/glow_round_corners.png \
+img/bevel_in.png \
+img/bevel_out.png \
+img/runner_horiz.png \
+img/runner_vert.png \
+img/runner_glow_horiz.png \
+img/runner_glow_vert.png \
+img/holes_tiny_horiz.png \
+img/holes_tiny_vert.png \
+img/holes_tiny_glow_horiz.png \
+img/holes_tiny_glow_vert.png \
+img/vgrad_med_lighter.png \
+img/glow_small.png \
+img/sym_left_light_normal.png \
+img/sym_right_light_normal.png \
+img/sym_up_light_normal.png \
+img/sym_down_light_normal.png \
+img/sym_left_glow_normal.png \
+img/sym_right_glow_normal.png \
+img/sym_up_glow_normal.png \
+img/sym_down_glow_normal.png \
+img/sym_up_dark_normal.png \
+img/sym_down_dark_normal.png \
+img/sym_left_dark_normal.png \
+img/sym_right_dark_normal.png \
+img/icon_folder.png \
+img/icon_file.png \
+img/icon_home.png \
+img/icon_arrow_up.png \
+img/icon_arrow_left.png