summaryrefslogtreecommitdiffstats
path: root/data/themes/ulticontroller_2.0/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/themes/ulticontroller_2.0/Makefile.am')
-rw-r--r--data/themes/ulticontroller_2.0/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/data/themes/ulticontroller_2.0/Makefile.am b/data/themes/ulticontroller_2.0/Makefile.am
new file mode 100644
index 0000000..4629bc3
--- /dev/null
+++ b/data/themes/ulticontroller_2.0/Makefile.am
@@ -0,0 +1,21 @@
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = Makefile.in
+
+EXTRA_DIST = \
+splashscreen.edc \
+images/ultimaker_logo.png
+
+include ../../../Makefile_Edje_Helper.am
+
+filesdir = $(datadir)/$(PACKAGE)/themes
+files_DATA = splashscreen.edj
+
+splashscreen.edj: Makefile $(EXTRA_DIST)
+ $(AM_V_EDJ)$(EDJE_CC) $(EDJE_CC_FLAGS) \
+ -id ${top_srcdir}/data/themes/ulticontroller_2.0/images \
+ -sd ${top_srcdir}/data/themes/ulticontroller_2.0/sounds \
+ $(top_srcdir)/data/themes/ulticontroller_2.0/splashscreen.edc \
+ $(top_builddir)/data/themes/ulticontroller_2.0/splashscreen.edj
+
+clean-local:
+ rm -f *.edj