summaryrefslogtreecommitdiffstats
path: root/src/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/bin/Makefile.am')
-rw-r--r--src/bin/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/bin/Makefile.am b/src/bin/Makefile.am
new file mode 100644
index 0000000..589f68d
--- /dev/null
+++ b/src/bin/Makefile.am
@@ -0,0 +1,19 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+bin_PROGRAMS = eulogium
+
+AM_CPPFLAGS = -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \
+-I$(top_builddir)/src/bin/ \
+-I$(top_srcdir)/src/bin/ \
+-I$(top_builddir)/src/lib/ \
+-I$(top_srcdir)/src/lib/ \
+@EFL_CFLAGS@
+
+eulogium_SOURCES = eulogium_main.c
+eulogium_LDADD = @EFL_LIBS@ $(top_builddir)/src/lib/libeulogium.la
+
+localedir = $(datadir)/locale
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+EXTRA_DIST = eulogium_private.h
+