summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joeyh@debian.org>2010-02-18 03:01:24 (GMT)
committerJoey Hess <joeyh@debian.org>2010-02-18 03:01:24 (GMT)
commit4ea13c421c17e100dbb8a532321d43f9be3b9677 (patch)
treefa8460aa8d2b897c05939fa7100e455aab940d77 /debian/rules
parent236117720cd5de5342d4b3dfbea35e5243490ae6 (diff)
downloaddebootstrap-4ea13c421c17e100dbb8a532321d43f9be3b9677.zip
debootstrap-4ea13c421c17e100dbb8a532321d43f9be3b9677.tar.gz
debootstrap-4ea13c421c17e100dbb8a532321d43f9be3b9677.tar.bz2
Convert rules file to use dh with overrides.
r62298
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules81
1 files changed, 24 insertions, 57 deletions
diff --git a/debian/rules b/debian/rules
index 87f0515..d40fe8d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,33 +1,34 @@
#! /usr/bin/make -f
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+%:
+ dh $@
-configure:
- dh_testdir
-
-clean:
- dh_testdir
- dh_auto_clean
- dh_clean
+# need to be root to make devices, so build is done in install target
+override_dh_auto_build:
-build: configure
-# need to be root to make devices, so build is done in install target
-
-real-build: build
- dh_testdir
- dh_testroot
+override_dh_auto_install:
dh_auto_build
+
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/debootstrap
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/debootstrap-udeb
+
+ # remove scripts not needed by d-i
+ -rm -rf debian/debootstrap-udeb/usr/share/debootstrap/scripts/potato \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/woody \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/sarge \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/warty \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/hoary \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/breezy \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/dapper \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/edgy \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/feisty \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/*.buildd \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/*.fakechroot \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/stable \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/testing \
+ debian/debootstrap-udeb/usr/share/debootstrap/scripts/unstable
-install: real-build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-# install the package into debian/debootstrap
- $(MAKE) install DESTDIR=$(CURDIR)/debian/debootstrap
- $(MAKE) install DESTDIR=$(CURDIR)/debian/debootstrap-udeb
ARCHES="i386"
SUITE="testing"
@@ -49,37 +50,3 @@ binary-basedebs:
rm -rf chroot-dir; \
done
rm -f scripts
-
-binary-indep: install
- dh_testdir
- dh_testroot
- dh_installdocs -i
- dh_installman -i
- dh_installchangelogs -i
- dh_link -i
- -rm -rf debian/debootstrap-udeb/usr/share/debootstrap/scripts/potato \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/woody \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/sarge \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/warty \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/hoary \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/breezy \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/dapper \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/edgy \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/feisty \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/*.buildd \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/*.fakechroot \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/stable \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/testing \
- debian/debootstrap-udeb/usr/share/debootstrap/scripts/unstable
- dh_compress -i
- dh_fixperms -i
- dh_installdeb -i
- dh_shlibdeps -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep binary-arch
-.PHONY: build real-build clean binary-indep binary-arch binary install configure binary-basedebs