summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2009-08-11 00:56:11 (GMT)
committerColin Watson <cjwatson@debian.org>2009-08-11 00:56:11 (GMT)
commitd6c8056efbf67bcebd960b534fc1890596b69646 (patch)
tree6b0abb4b9a9de0d77b029667f150c5ec2b664df7 /debian/rules
parent9e7d96f50df440f1ce1432e44f774799d4e5c0c0 (diff)
downloaddebootstrap-d6c8056efbf67bcebd960b534fc1890596b69646.zip
debootstrap-d6c8056efbf67bcebd960b534fc1890596b69646.tar.gz
debootstrap-d6c8056efbf67bcebd960b534fc1890596b69646.tar.bz2
Upgrade to debhelper v7. (Override rules get pretty hairy for this
package, so I haven't switched to dh(1).) r60091
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 5 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index d09c015..f48d5a6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,4 @@
-#!/usr/bin/make -f
+#! /usr/bin/make -f
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -8,9 +8,7 @@ configure:
clean:
dh_testdir
-
- $(MAKE) clean
-
+ dh_auto_clean
dh_clean
build: configure
@@ -19,14 +17,12 @@ build: configure
real-build: build
dh_testdir
dh_testroot
-
- $(MAKE) all
+ dh_auto_build
install: real-build
dh_testdir
dh_testroot
-
- dh_clean -k
+ dh_prep
dh_installdirs
# install the package into debian/debootstrap
@@ -58,7 +54,7 @@ binary-indep: install
dh_testdir
dh_testroot
dh_installdocs -i
- dh_installman -i debootstrap.8
+ dh_installman -i
dh_installchangelogs -i
dh_link -i
-rm -rf debian/debootstrap-udeb/usr/share/debootstrap/scripts/potato \