summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorFrans Pop <fjp@debian.org>2007-11-13 11:36:44 (GMT)
committerFrans Pop <fjp@debian.org>2007-11-13 11:36:44 (GMT)
commiteae4f2582e21a1c6b266e78592fdc52d14caf0a8 (patch)
tree6ca87e8aba1a321c2cbe4660c1f4273661443831 /debian/rules
parent9ceb341b602c7a61164ab285f5ba66ba2fe5b29d (diff)
downloaddebootstrap-eae4f2582e21a1c6b266e78592fdc52d14caf0a8.zip
debootstrap-eae4f2582e21a1c6b266e78592fdc52d14caf0a8.tar.gz
debootstrap-eae4f2582e21a1c6b266e78592fdc52d14caf0a8.tar.bz2
Make debootstrap-udeb 'Architecture: all'
For this to be possible, the utility pkgdetails is moved from debootstrap to base-installer r50114
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 10 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index 99383a7..abc8232 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,7 +31,7 @@ install: real-build
# install the package into debian/debootstrap
$(MAKE) install DESTDIR=$(CURDIR)/debian/debootstrap
- $(MAKE) install-udeb DESTDIR=$(CURDIR)/debian/debootstrap-udeb
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/debootstrap-udeb
binary-indep: install
# We have nothing to do by default.
@@ -64,17 +64,6 @@ binary-indep: install
dh_installman -i debootstrap.8
dh_installchangelogs -i
dh_link -i
- dh_compress -i
- dh_fixperms -i
- dh_installdeb -i
- dh_shlibdeps -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch: install
- dh_testdir
- dh_testroot
-rm -rf debian/debootstrap-udeb/usr/share \
debian/debootstrap-udeb/usr/lib/debootstrap/scripts/potato \
debian/debootstrap-udeb/usr/lib/debootstrap/scripts/woody \
@@ -87,13 +76,15 @@ binary-arch: install
debian/debootstrap-udeb/usr/lib/debootstrap/scripts/feisty \
debian/debootstrap-udeb/usr/lib/debootstrap/scripts/*.buildd \
debian/debootstrap-udeb/usr/lib/debootstrap/scripts/*.fakechroot
- dh_strip -s
- dh_compress -s
- dh_fixperms -s
- dh_installdeb -s
- dh_shlibdeps -s
- dh_gencontrol -s
- dh_builddeb -s
+ dh_compress -i
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_shlibdeps -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
binary: binary-indep binary-arch
.PHONY: build real-build clean binary-indep binary-arch binary install configure binary-basedebs