summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2011-05-20 08:33:34 (GMT)
committerColin Watson <cjwatson@debian.org>2011-05-20 08:33:34 (GMT)
commit376a60e9041e76c2331b12db5611e82930e683bf (patch)
tree7a5bfae6d921aebedb7b1fc11905e79a77047672 /debian
parent4bab1a20741b9864445d3f5c0203697ed52ea224 (diff)
downloaddebootstrap-376a60e9041e76c2331b12db5611e82930e683bf.zip
debootstrap-376a60e9041e76c2331b12db5611e82930e683bf.tar.gz
debootstrap-376a60e9041e76c2331b12db5611e82930e683bf.tar.bz2
Recommend ubuntu-keyring rather than debian-archive-keyring on Ubuntu-derived systems.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules9
3 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 62f2f86..68be597 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ debootstrap (1.0.31) UNRELEASED; urgency=low
* If ubuntu-keyring is installed, check Release signatures against it when
bootstrapping Ubuntu gutsy and later.
+ * Recommend ubuntu-keyring rather than debian-archive-keyring on
+ Ubuntu-derived systems.
-- Colin Watson <cjwatson@debian.org> Fri, 20 May 2011 09:26:48 +0100
diff --git a/debian/control b/debian/control
index ef59108..ad993d4 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,7 @@ Vcs-Git: git://git.debian.org/d-i/debootstrap.git
Package: debootstrap
Architecture: all
Depends: ${misc:Depends}, wget
-Recommends: gnupg, debian-archive-keyring
+Recommends: gnupg, ${keyring:Recommends}
Description: Bootstrap a basic Debian system
debootstrap is used to create a Debian base system from scratch,
without requiring the availability of dpkg or apt. It does this by
diff --git a/debian/rules b/debian/rules
index cc9c27c..03d5c5f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,11 @@
#! /usr/bin/make -f
+ifeq (0,$(shell dpkg-vendor --derives-from Ubuntu; echo $$?))
+ KEYRING := ubuntu-keyring
+else
+ KEYRING := debian-archive-keyring
+endif
+
%:
dh $@
@@ -27,3 +33,6 @@ override_dh_auto_install:
debian/debootstrap-udeb/usr/share/debootstrap/scripts/stable \
debian/debootstrap-udeb/usr/share/debootstrap/scripts/testing \
debian/debootstrap-udeb/usr/share/debootstrap/scripts/unstable
+
+override_dh_gencontrol:
+ dh_gencontrol -- -Vkeyring:Recommends=$(KEYRING)