summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2016-02-05 10:36:22 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2016-03-10 09:37:39 (GMT)
commit660f1a8cc94f7176f49d5021e7b979030c5ac42e (patch)
tree9de61b286e8bb59dd9f74280082c3dcac14b8585 /configure.ac
parent398af5331bacd2e2aa4914e9926bf32d28cf8c14 (diff)
downloadengagement-660f1a8cc94f7176f49d5021e7b979030c5ac42e.zip
engagement-660f1a8cc94f7176f49d5021e7b979030c5ac42e.tar.gz
engagement-660f1a8cc94f7176f49d5021e7b979030c5ac42e.tar.bz2
Add empty eflprj generated skeleton project
Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac102
1 files changed, 102 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..cf20b6a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,102 @@
+EFL_VERSION([0], [0], [1], [dev])
+AC_INIT([engagement], [efl_version], [enlightenment-devel@lists.sourceforge.net])
+
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([configure.ac])
+AC_CONFIG_HEADERS([config.h])
+
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+
+AM_INIT_AUTOMAKE([1.10 dist-bzip2 -Wall color-tests])
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+AM_PROG_AR
+
+# this will speed up libtool checks
+LT_PREREQ([2.2])
+LT_INIT([win32-dll pic-only])
+EFL_INIT
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+EFL_ATTRIBUTE_UNUSED
+ELM_QUICKLAUNCH
+EFL_COMPILER_FLAG([-Wall])
+EFL_COMPILER_FLAG([-W])
+
+# Checks for header files.
+EFL_CHECK_PATH_MAX
+
+# Check for EFL
+PKG_CHECK_MODULES([EFL],
+[
+ eina >= 1.8.0
+ evas >= 1.8.0
+ ecore >= 1.8.0
+ edje >= 1.8.0
+ elementary >= 1.8.0
+])
+
+# Check for tests and coverage
+AC_ARG_WITH([tests],
+ [AS_HELP_STRING([--with-tests=none|regular|coverage],
+ [choose testing method: regular, coverage or none.
+ @<:@default=none@:>@])],
+ [build_tests=${withval}],
+ [build_tests=auto])
+
+EFL_TESTS([${build_tests}])
+
+# doxygen program for documentation building
+EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"])
+
+# Check edje_cc
+EFL_WITH_BIN([edje], [edje-cc], [edje_cc])
+
+# Check locale
+AC_CHECK_FUNCS([setlocale])
+AC_CHECK_HEADERS([locale.h])
+
+AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT([external])
+AC_CHECK_HEADERS([libintl.h])
+AC_C_INLINE
+AC_FUNC_MALLOC
+
+AC_CONFIG_FILES([
+Makefile
+data/Makefile
+data/desktop/Makefile
+data/desktop/engagement.desktop
+data/themes/Makefile
+data/themes/default/Makefile
+doc/Makefile
+packaging/Makefile
+packaging/slackware/Makefile
+packaging/pkgbuild/Makefile
+po/Makefile.in
+src/Makefile
+src/bin/Makefile
+src/lib/Makefile
+src/tests/Makefile
+doc/engagement.1
+])
+AC_OUTPUT
+
+echo
+echo
+echo "------------------------------------------------------------------------"
+echo "$PACKAGE_NAME $PACKAGE_VERSION"
+echo "------------------------------------------------------------------------"
+echo
+echo "Compilation..............: make (or gmake)"
+echo " CFLAGS.................: $CFLAGS"
+echo " edje_cc................: ${edje_cc}"
+echo
+echo "Building documentation...: ${build_doc}"
+echo "Building tests...........: ${have_tests}"
+echo "Generate coverage .......: ${have_lcov}"
+echo
+echo "Installation.............: make install (as root if needed, with 'su' or 'sudo')"
+echo " prefix.................: $prefix"
+echo