summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2016-03-11 08:17:17 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2016-03-18 20:42:52 (GMT)
commit6cd8ff8f7101091559fa60535cb26d7c30b23fdf (patch)
tree55ddbc6b8a7a07ef6dc51b2136406b87198aed76 /configure.ac
parente6221575eaca0471436af92190542597fc1b8998 (diff)
downloadengagement-6cd8ff8f7101091559fa60535cb26d7c30b23fdf.zip
engagement-6cd8ff8f7101091559fa60535cb26d7c30b23fdf.tar.gz
engagement-6cd8ff8f7101091559fa60535cb26d7c30b23fdf.tar.bz2
Add support for libdl to configure.ac
Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1876d8f..e8b8193 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,10 @@ AC_CHECK_HEADERS([libintl.h])
AC_C_INLINE
AC_FUNC_MALLOC
+# FreeBSD doesn't have libdl, dlopen is provided by libc
+AC_CHECK_FUNC(dlopen, LIBDL="", [AC_CHECK_LIB([dl], [dlopen], LIBDL="-ldl")])
+AC_SUBST(LIBDL)
+
AC_CONFIG_FILES([
Makefile
data/Makefile