summaryrefslogtreecommitdiffstats
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2016-03-11 08:11:32 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2016-03-18 20:46:27 (GMT)
commit32fb990072022f7668930473e07c3ae0eb3d8215 (patch)
tree79736e547aea85e597f403e24f84f06cb19c6541 /src/lib/Makefile.am
parent6cd8ff8f7101091559fa60535cb26d7c30b23fdf (diff)
downloadengagement-32fb990072022f7668930473e07c3ae0eb3d8215.zip
engagement-32fb990072022f7668930473e07c3ae0eb3d8215.tar.gz
engagement-32fb990072022f7668930473e07c3ae0eb3d8215.tar.bz2
Add initial plugin header
This patch adds the first preliminary draft plugin description. It is missing many things, most importantly documentation. More importantly it is likely not yet complete. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 0eaf568..fc64133 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -3,6 +3,7 @@ MAINTAINERCLEANFILES = Makefile.in
AM_CPPFLAGS = \
-I$(top_srcdir)/src/lib \
-I$(top_builddir)/src/lib \
+-I$(top_srcdir)/src/include \
-DPACKAGE_LIB_DIR=\"$(libdir)\" \
-DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \
@EFL_CFLAGS@ \
@@ -13,6 +14,6 @@ lib_LTLIBRARIES = libengagement.la
includes_HEADERS = engagement.h
includesdir = $(includedir)/engagement-@VMAJ@
-libengagement_la_SOURCES = engagement.c
-libengagement_la_LIBADD = @EFL_LIBS@ -lm
+libengagement_la_SOURCES = engagement.c plugin.c
+libengagement_la_LIBADD = @EFL_LIBS@ @LIBDL@
libengagement_la_LDFLAGS = @EFL_LTLIBRARY_FLAGS@