summaryrefslogtreecommitdiffstats
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2016-03-11 08:24:07 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2016-03-18 20:46:27 (GMT)
commit6c119ae1e935646f7366f3f6d438a125dcbe1f98 (patch)
tree1fbb225e70bc4607a42e53aa9d382133a286dcea /src/plugins/Makefile.am
parent24c187b0ba2939a80755a98fec8a625fc7d453f9 (diff)
downloadengagement-6c119ae1e935646f7366f3f6d438a125dcbe1f98.zip
engagement-6c119ae1e935646f7366f3f6d438a125dcbe1f98.tar.gz
engagement-6c119ae1e935646f7366f3f6d438a125dcbe1f98.tar.bz2
Add preliminary ical experiments
This patch adds preliminary 'support' for iCalendar. Preliminary in the sense that it opens a known file, and prints some output using printf. This is just some experiments in parsing ics files. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
new file mode 100644
index 0000000..b5e5002
--- /dev/null
+++ b/src/plugins/Makefile.am
@@ -0,0 +1,20 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+AM_CPPFLAGS = \
+-I$(top_srcdir)/src/plugins \
+-I$(top_builddir)/src/plugins \
+-I$(top_srcdir)/src/include \
+-DPACKAGE_LIB_DIR=\"$(libdir)\" \
+-DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\"
+
+lib_LTLIBRARIES = libcalendar_example.la \
+ libcalendar_ical.la libcalendar_caldav.la
+
+libcalendar_example_la_SOURCES = calendar_example.c
+libcalendar_example_la_LIBADD =
+
+libcalendar_ical_la_SOURCES = calendar_ical.c
+libcalendar_ical_la_LIBADD = @LIBICAL@
+
+libcalendar_caldav_la_SOURCES = calendar_caldav.c
+libcalendar_caldav_la_LIBADD = -lical # @LIBICAL@