summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1876d8f..e8b8193 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,10 @@ AC_CHECK_HEADERS([libintl.h])
AC_C_INLINE
AC_FUNC_MALLOC
+# FreeBSD doesn't have libdl, dlopen is provided by libc
+AC_CHECK_FUNC(dlopen, LIBDL="", [AC_CHECK_LIB([dl], [dlopen], LIBDL="-ldl")])
+AC_SUBST(LIBDL)
+
AC_CONFIG_FILES([
Makefile
data/Makefile