summaryrefslogtreecommitdiffstats
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
new file mode 100644
index 0000000..2f1e8fb
--- /dev/null
+++ b/src/tests/Makefile.am
@@ -0,0 +1,17 @@
+
+if EFL_HAVE_TESTS
+
+check_PROGRAMS = engagement_tests
+
+engagement_tests_SOURCES = test_engagement.c
+engagement_tests_CPPFLAGS = -I$(top_builddir)/src/lib/ \
+-DPACKAGE_TESTS_DIR=\"$(top_srcdir)/src/tests/\" \
+-DPACKAGE_BUILD_DIR=\"`pwd`/$(top_builddir)/src/tests/\" \
+@EFL_CFLAGS@ \
+@CHECK_CFLAGS@
+engagement_tests_LDADD = @CHECK_LIBS@ $(top_builddir)/src/lib/libengagement.la
+engagement_tests_DEPENDENCIES = $(top_builddir)/src/lib/libengagement.la
+
+endif
+
+EXTRA_DIST = test_engagement.c