summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2015-01-24 13:53:43 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2015-01-24 14:18:21 (GMT)
commit08cfb908c22c0c7b5aeb788569950718939b7465 (patch)
tree6602640dc6b8dafaa3605d9cc3e955e66581d1e9 /configure.ac
parente13c3bc4aeba38f4f70754d8e73985eafb23a290 (diff)
downloadeulogium-08cfb908c22c0c7b5aeb788569950718939b7465.zip
eulogium-08cfb908c22c0c7b5aeb788569950718939b7465.tar.gz
eulogium-08cfb908c22c0c7b5aeb788569950718939b7465.tar.bz2
EFL empty project
Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac98
1 files changed, 98 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5af30e4
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,98 @@
+EFL_VERSION([0], [0], [1], [dev])
+AC_INIT([eulogium], [efl_version], [enlightenment-devel@lists.sourceforge.net])
+
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([configure.ac])
+AC_CONFIG_HEADERS([config.h])
+
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+
+AM_INIT_AUTOMAKE([1.10 dist-bzip2 -Wall color-tests])
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+AM_PROG_AR
+
+# this will speed up libtool checks
+LT_PREREQ([2.2])
+LT_INIT([win32-dll pic-only])
+EFL_INIT
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+EFL_ATTRIBUTE_UNUSED
+ELM_QUICKLAUNCH
+EFL_COMPILER_FLAG([-Wall])
+EFL_COMPILER_FLAG([-W])
+
+# Checks for header files.
+EFL_CHECK_PATH_MAX
+
+# Check for EFL
+PKG_CHECK_MODULES([EFL],
+[
+ eina >= 1.8.0
+ evas >= 1.8.0
+ ecore >= 1.8.0
+ edje >= 1.8.0
+ elementary >= 1.8.0
+])
+
+# Check for tests and coverage
+AC_ARG_WITH([tests],
+ [AC_HELP_STRING([--with-tests=none|regular|coverage],
+ [choose testing method: regular, coverage or none.
+ @<:@default=none@:>@])],
+ [build_tests=${withval}],
+ [build_tests=auto])
+
+EFL_TESTS([${build_tests}])
+
+# doxygen program for documentation building
+EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"])
+
+# Check edje_cc
+EFL_WITH_BIN([edje], [edje-cc], [edje_cc])
+
+# Checks for library functions.
+AC_CHECK_FUNCS([setlocale])
+
+AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT([external])
+
+AC_CONFIG_FILES([
+Makefile
+data/Makefile
+data/desktop/Makefile
+data/desktop/eulogium.desktop
+data/themes/Makefile
+data/themes/default/Makefile
+doc/Makefile
+packaging/Makefile
+packaging/slackware/Makefile
+packaging/pkgbuild/Makefile
+po/Makefile.in
+src/Makefile
+src/bin/Makefile
+src/lib/Makefile
+src/tests/Makefile
+doc/eulogium.1
+])
+AC_OUTPUT
+
+echo
+echo
+echo "------------------------------------------------------------------------"
+echo "$PACKAGE_NAME $PACKAGE_VERSION"
+echo "------------------------------------------------------------------------"
+echo
+echo "Compilation..............: make (or gmake)"
+echo " CFLAGS.................: $CFLAGS"
+echo " edje_cc................: ${edje_cc}"
+echo
+echo "Building documentation...: ${build_doc}"
+echo "Building tests...........: ${have_tests}"
+echo "Generate coverage .......: ${have_lcov}"
+echo
+echo "Installation.............: make install (as root if needed, with 'su' or 'sudo')"
+echo " prefix.................: $prefix"
+echo