summaryrefslogtreecommitdiffstats
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2015-01-24 13:53:43 (GMT)
committerOlliver Schinagl <oliver@schinagl.nl>2015-01-24 14:18:21 (GMT)
commit08cfb908c22c0c7b5aeb788569950718939b7465 (patch)
tree6602640dc6b8dafaa3605d9cc3e955e66581d1e9 /src/tests/Makefile.am
parente13c3bc4aeba38f4f70754d8e73985eafb23a290 (diff)
downloadeulogium-08cfb908c22c0c7b5aeb788569950718939b7465.zip
eulogium-08cfb908c22c0c7b5aeb788569950718939b7465.tar.gz
eulogium-08cfb908c22c0c7b5aeb788569950718939b7465.tar.bz2
EFL empty project
Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
new file mode 100644
index 0000000..8ae8c20
--- /dev/null
+++ b/src/tests/Makefile.am
@@ -0,0 +1,17 @@
+
+if EFL_HAVE_TESTS
+
+check_PROGRAMS = eulogium_tests
+
+eulogium_tests_SOURCES = test_eulogium.c
+eulogium_tests_CPPFLAGS = -I$(top_builddir)/src/lib/ \
+-DPACKAGE_TESTS_DIR=\"$(top_srcdir)/src/tests/\" \
+-DPACKAGE_BUILD_DIR=\"`pwd`/$(top_builddir)/src/tests/\" \
+@EFL_CFLAGS@ \
+@CHECK_CFLAGS@
+eulogium_tests_LDADD = @CHECK_LIBS@ $(top_builddir)/src/lib/libeulogium.la
+eulogium_tests_DEPENDENCIES = $(top_builddir)/src/lib/libeulogium.la
+
+endif
+
+EXTRA_DIST = test_eulogium.c