summaryrefslogtreecommitdiffstats
path: root/data/themes/ulticontroller_2.0/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/themes/ulticontroller_2.0/Makefile.am')
-rw-r--r--data/themes/ulticontroller_2.0/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/data/themes/ulticontroller_2.0/Makefile.am b/data/themes/ulticontroller_2.0/Makefile.am
new file mode 100644
index 0000000..94026ed
--- /dev/null
+++ b/data/themes/ulticontroller_2.0/Makefile.am
@@ -0,0 +1,38 @@
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = Makefile.in
+
+include ../../../Makefile_Edje_Helper.am
+
+images = \
+images/ultimaker_logo.png
+
+fonts = \
+fonts/5x8.pcf.gz
+
+sounds = \
+sounds/what.wav
+
+data =
+
+edjes = \
+splashscreen.edc \
+mainscreen.edc
+
+ULTICONTROLLER_CC_FLAGS = \
+-id ${top_srcdir}/data/themes/ulticontroller_2.0/images \
+-fd ${top_srcdir}/data/themes/ulticontroller_2.0/fonts \
+-sd ${top_srcdir}/data/themes/ulticontroller_2.0/sounds \
+-dd ${top_srcdir}/data/themes/ulticontroller_2.0/data
+
+EXTRA_DIST = $(images) $(sounds) $(iamges) $(edjes)
+
+filesdir = $(datadir)/$(PACKAGE)/themes
+files_DATA = eulogium.edj
+
+eulogium.edj: Makefile $(EXTRA_DIST)
+ $(AM_V_EDJ)$(EDJE_CC) $(EDJE_CC_FLAGS) $(ULTICONTROLLER_CC_FLAGS) \
+ $(top_srcdir)/data/themes/ulticontroller_2.0/ulticontroller_2.0.edc \
+ $(top_builddir)/data/themes/ulticontroller_2.0/eulogium.edj
+
+clean-local:
+ rm -f *.edj