summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2011-05-20 08:33:34 (GMT)
committerColin Watson <cjwatson@debian.org>2011-05-20 08:33:34 (GMT)
commit376a60e9041e76c2331b12db5611e82930e683bf (patch)
tree7a5bfae6d921aebedb7b1fc11905e79a77047672 /debian/rules
parent4bab1a20741b9864445d3f5c0203697ed52ea224 (diff)
downloaddebootstrap-376a60e9041e76c2331b12db5611e82930e683bf.zip
debootstrap-376a60e9041e76c2331b12db5611e82930e683bf.tar.gz
debootstrap-376a60e9041e76c2331b12db5611e82930e683bf.tar.bz2
Recommend ubuntu-keyring rather than debian-archive-keyring on Ubuntu-derived systems.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index cc9c27c..03d5c5f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,11 @@
#! /usr/bin/make -f
+ifeq (0,$(shell dpkg-vendor --derives-from Ubuntu; echo $$?))
+ KEYRING := ubuntu-keyring
+else
+ KEYRING := debian-archive-keyring
+endif
+
%:
dh $@
@@ -27,3 +33,6 @@ override_dh_auto_install:
debian/debootstrap-udeb/usr/share/debootstrap/scripts/stable \
debian/debootstrap-udeb/usr/share/debootstrap/scripts/testing \
debian/debootstrap-udeb/usr/share/debootstrap/scripts/unstable
+
+override_dh_gencontrol:
+ dh_gencontrol -- -Vkeyring:Recommends=$(KEYRING)