summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joeyh@debian.org>2010-02-18 03:04:40 (GMT)
committerJoey Hess <joeyh@debian.org>2010-02-18 03:04:40 (GMT)
commitad81de99584bb68b991ed6f82015b2c2e64cceb6 (patch)
tree6622145a327f79d72b44cc6eb43871fb7ba1e99a /debian/rules
parent4ea13c421c17e100dbb8a532321d43f9be3b9677 (diff)
downloaddebootstrap-ad81de99584bb68b991ed6f82015b2c2e64cceb6.zip
debootstrap-ad81de99584bb68b991ed6f82015b2c2e64cceb6.tar.gz
debootstrap-ad81de99584bb68b991ed6f82015b2c2e64cceb6.tar.bz2
Remove binary-basedebs target from debian/rules.
This target has been broken in multiple ways since 2007. While I accidentially partially fixed it with the above changes, this is evidence it's dead code that can be safely removed. r62299
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 0 insertions, 23 deletions
diff --git a/debian/rules b/debian/rules
index d40fe8d..82a487e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,26 +27,3 @@ override_dh_auto_install:
debian/debootstrap-udeb/usr/share/debootstrap/scripts/stable \
debian/debootstrap-udeb/usr/share/debootstrap/scripts/testing \
debian/debootstrap-udeb/usr/share/debootstrap/scripts/unstable
-
-
-
-ARCHES="i386"
-SUITE="testing"
-VERSION=$(SUITE)
-MIRROR="http://ftp.us.debian.org/debian"
-
-binary-basedebs:
- dh_testdir
- dh_testroot
-
- $(MAKE) pkgdetails
-
- ln -s . scripts
- for a in $(ARCHES); do \
- rm -rf chroot-dir; \
- mkdir -p chroot-dir; \
- DEBOOTSTRAP_DIR=. ./debootstrap --arch $$a --download-only $(SUITE) chroot-dir $(MIRROR); \
- (cd chroot-dir && tar cf ../../basedebs_$(VERSION)_$$a.tar *); \
- rm -rf chroot-dir; \
- done
- rm -f scripts