summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 15871c9..a0417e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,18 @@
MAINTAINERCLEANFILES = Makefile.in
-SUBDIRS = lib bin tests
+SUBDIRS = tests
+bin_PROGRAMS = eulogium
+
+AM_CPPFLAGS = -DPACKAGE_BIN_DIR=\"$(bindir)/\" \
+ -DPACKAGE_LIB_DIR=\"$(bindir)/\" \
+ -DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \
+-I$(top_builddir)/src/ \
+-I$(top_srcdir)/src/ \
+@EFL_CFLAGS@
+
+eulogium_SOURCES = eulogium.c
+eulogium_LDADD = @EFL_LIBS@
+
+localedir = $(datadir)/locale
+DEFS = -DLOCALE_DIR=\"$(localedir)\" @DEFS@